Monitor USB AOC E1649FWU - DISPLAYLINK en Linux (Opens Suse en Especifico


La información que se encuentra en internet, dicen que hay que hacer blacklist el udlfb que es el driver viejo de este tipo de monitores, y utilizar el udl, pero al hacerlo se ve esto:


Por lo tanto, pues no sirve, asi que lo que sigue es, ir a la página del fabrincante del "display link chip"


Descargar Drivers
http://www.displaylink.com/downloads/ubuntu

Dar permisos de ejecución a instalador.

Ejecutar de la siguiente forma
./displaylink-driver-(version) --noexec –keep


El script de instalación es:
displaylink-installer.sh
pero solo sirve para Ubuntu, así que, en base a ese archivo, extraigo las siguientes indicaciones:

Agregar la configuracion para el udev

  echo 'ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="17e9", ATTR{bNumInterfaces}=="*5", GROUP="plugdev", MODE="0660"' > /etc/udev/rules.d/99-displaylink.rules
  chmod 0644 /etc/udev/rules.d/99-displaylink.rules


Dependiendo de a arquitectura (x86 o x64)
Copiar el archivo DisplayLinkManager a
mkdir /usr/lib/displaylink
chdir /usr/lib/displaylink
cp DisplayLinkManager /usr/lib/displaylink
chmod 555 /usr/lib/displaylink/DisplayLink/Manager

Agregar la unidad para systemd, para el caso de opensuse uso:
cat > /etc/systemd/system/displaylink.service <<'EOF'
para caso ubuntu es:
cat > /lib/systemd/system/displaylink.service <<'EOF'
[Unit]
Description=DisplayLink Manager Service
After=display-manager.service
Conflicts=getty@tty7.service

[Service]
ExecStartPre=/sbin/modprobe evdi
ExecStart=/usr/lib/displaylink/DisplayLinkManager
Restart=always
WorkingDirectory=/usr/lib/displaylink
RestartSec=5

[Install]
WantedBy=graphical.target

EOF

Se le da permisos de ejecución
 chmod 0644 /lib/systemd/system/displaylink.service
Se habilita en systemd
 systemctl enable displaylink.service


Se copia libevdi.so a /usr/lib64
Se descompacta el codigo del módulo y se compila
tar -xvzf evdi-1.0.335-src.tar.gz
make
Deja todos los archivos allí mismo, se ejecuta make
y genera:
evdi.ko

Lo copio a un directorio "bueno" en este caso lo puse en:
cp evdi.ko  /lib/modules/uname -r/kernel/drivers/usb/misc/evdi.ko

Reinicio y veo que ya este todo funcionando.


Una última nota, el driver, es tragon de CPU... pero el monitor se ve muy claro.

Previous
Next Post »